VR Dashboard v3.12.10
Post by iconPost by Hardtack | 2020-11-15 | 01:29:53

I just uploaded a new version. Google approval is still pending.
More details below.

commenticon 30 Comments
Post by iconPost by Hardtack | 2020-11-15 | 01:30:24
* Stale position warning
If the boat position is outdated by more than 10min, a warning is issued when calling the router.
Thanks to Cvetan for suggesting this.

* Show track info
Please turn off if you observe sluggish behavior
This utterly cool feature was introduced in 3.12.7.
If switched on, boat actions (manual or programmed heading or TWA changes) are displayed on the boat track. Hover the mouse over the black dots to see them.
Unfortunately, this feature may overload the map and cause the dashboard to become unresponsive. Also it was accidentally turned on by default.
With version 3.12.10 track info is only displayed for your own and followed boats. Sluggishness or unresponsiveness may still occur, if you have many followed boats.

* Column 'Hull' replaced with column 'Options'
The new VR protocol provides a boat's options in the boatinfo (formerly "UserCard") message.
If the UserCard is available, boat options are displayed here.

* Restore AutoSail and TWA/Heading lock indication
These were broken because of changed VR messages.


Update
I've seen issues with auto-calling the router, at least when the engine is down. Not sure how this could happen. Auto-calling the router is the one feature I always test before releasing anything :-(
You still get the position update (if there is one) and can call the router using the 'Go' button or helm icon.



Post by iconPost by BooBill | 2020-11-15 | 01:48:09
Michael, is there any way for you to extract the estimated position during these frequent server crashes? The boat is moving as it should on screen, so the client is calculating a position.

BTW, those upgrades sound totally cool. Can't wait to play with then.

Post by iconPost by Hardtack | 2020-11-15 | 01:58:27
The Dashboard only sees the information exchanged with the server. The estimated position is client-side only.
Post by iconPost by BooBill | 2020-11-15 | 02:01:31
I asked a related question in a separate post. What' happens to commands, bearing changes, you issue while the game clock is froze? Are those being received by the server and cached to be executed when it comes back?
Post by iconPost by Hardtack | 2020-11-15 | 02:21:41
VRDashboard displays the server response. If you see a 'command' line in the Race Log, the command was received by the server.

I don't know about the second part of your question. They might fast-forward the simulation, executing any commands, or resume simulation using the new time and the old position, discarding the commands. The race log should tell us, but I didn't check it last time.



Post by iconPost by BooBill | 2020-11-15 | 02:47:50
That's good news I guess. You could set a bearing and go with that and be safe. Or, if you've been following a route, you'd have the coordinates you should be at in the Route Zezo.org extension. So, you could run a new route using your own estimate of your position. Commands, programs you create then should be received and eventually executed? Does that make sense, or am I being overly optimistic here?

Thankfully we are in open water with a relatively straight course. This could have been a lot tougher.
Post by iconPost by Russel1 FIN | 2020-11-15 | 13:23:44
SOLVED, see "Update" in the opening message // Hi, I got the Chrome extension updated to version 3.12.10 and don't get route plan, the route tab does not open at all - anyone else having this problem?

Post by iconPost by Hardtack | 2020-11-15 | 13:29:14
See my first message in the thread.

Your position (or whatever the VR engine currently thinks it is) is received by VRDashboard.

Just call the router manually for now.
Post by iconPost by Russel1 FIN | 2020-11-15 | 13:32:22
Thanks, just noticed it and was bout to edit my question :-)
Post by iconPost by WakeUp650 | 2020-11-15 | 15:53:51
Hi Zezo team,
Once more thanks a lot for recent improvements such as the 'options' column. You are doing such a great job. Thank you again and take care.

Post by iconPost by Sayber | 2020-11-15 | 16:01:49
Just a question, sometimes there is a big red line as isochrone, what is it for ?
Post by iconPost by BooBill | 2020-11-15 | 16:06:20
The red line means it is in the process of downloading a weather update. The line is the divide between new forecast and old one.
Post by iconPost by DeskSailor | 2020-11-15 | 18:28:32
Thanks, Hardtack, always appreciate the work put in here by all the experts.
Post by iconPost by Jeanbern19 | 2020-11-15 | 20:36:31
Thank you
this version works perfectly

Bernard
Post by iconPost by Caaparn | 2020-11-16 | 10:15:46
Hi
I use a Mac and upgraded to OS X Big Sur. After that Chrome does not work with the game anymore.
But I saw that in the new Safari (in Big Sur) it is possible to "easily" convert Chrome extensions to Safari.
I know that we Mac users are in minority, but for us it would be fantastic if we could use Safari with your extension.
So I fully understand if you don't feel/have time to make the conversion but anyway hoping for the best.

PS Your extension is so useful. Good work! :-)

Greetings from JustGo

Post by iconPost by zezo | 2020-11-16 | 10:40:58
I'm not 100% sure about extensions, but in genera developing and publishing something for Mac requires at leas two things:

1) Having a Mac
2) Having a paid Apple developer account

It should be possible to get a working setup using some other chromium based browser like Opera or even MS Edge. It was discussed recently here:

http://zezo.org/forum.pl?tid=8111
Post by iconPost by rids | 2020-11-16 | 12:11:08
The edge of the IEZ looks like a pedestrian crossing when zoomed in. is the speed penalty already effctive if you cross the lighter areas , or is it just a warning signal ?

Cheers
Post by iconPost by Hardtack | 2020-11-21 | 10:41:31
Version 3.12.11 is out.

Changes:
- Fleet tab: Filtering and sorting works again. Added a filter for 'Certified' players
- Race status & Race log: Stale position updates displayed in red

As in the previous version router is not called automatically if the position is stale. This is intentional. Due to a browser security feature the Dashboard can't show a popup if it is not the active tab however.
Post by iconPost by Inicio | 2020-11-21 | 11:17:50
Thanks a lot!
Post by iconPost by kalle | 2020-11-21 | 13:00:09
It seems that "the last command" remember a programmed setup. Even if I delete the progamming. Eks I go twa 123,00. I program for 120. First it jumps to 120,01.
If I delete the 120,01 its gone, but now I see twa 123,01 in 10 minutes.????

Hope I made it clear enough.

kallemans
Post by iconPost by Hardtack | 2020-11-21 | 14:45:40
Works fine for me. Programmed commands are removed from the 'Last Command' field when I delete them in the game, and immediate commands are shown without a scheduled time. The Race log shows the history of all the changes I made.

Are you saying that you immediate command is converted to a programmed command 10min ahead when you delete a programmed command? When does the boat actually execute the course changes (according to Dashboard)?

Post by iconPost by zezo | 2020-11-21 | 16:21:01
Keep in mind that (at least in the last protocol version I checked) all commands are issued with client-side time stamp. So if your PC clock is 10 minutes ahead your simple turn is actually programmed 10 minutes in the future.
Post by iconPost by kalle | 2020-11-22 | 08:46:52
@Hardtack. Yes thats what i am saying. It keeps the non excact twa 10 minutes out. If im not doing a new excact twa shedule the boat take the "false one".So to me it looks like it dosent clear all "last command" field.

I will try to do some screenshot of it. But im not sure how to upload them here?

kallemans
Post by iconPost by Hardtack | 2020-11-22 | 09:21:34
Did you check your PC clock as Cvetan suggested? This could be the reason. It's an immediate command but it appears 10min in the future because your clock is 10 minutes fast. Immediate commands can not be deleted.


Post by iconPost by kalle | 2020-11-22 | 13:35:52
Yes i have check the clock. Its fine. I deleted the extension and build in a new one. Same problem. I have a screenshot i like you to see. How can we arrange that?

It shows my commands

kallemans
Post by iconPost by Hardtack | 2020-11-22 | 14:06:05
You can upload the image on imgbb.com, for example. You'll get a link that you can post here.
Post by iconPost by kalle | 2020-11-22 | 13:42:53
I have used dashboard some years now, and i havent seen this problem before. Problem comes when i am deleting progamming.
Post by iconPost by kalle | 2020-11-22 | 15:52:58
https://ibb.co/HBDkrPs


@Hardtack. Hope it works. For your information I have several friends who have the same issue. As I said it is on a problem when I delete further programs. Once I have an excact course I can build out with no problem.

Thank you for your time on this issue.

Eventually try it your self. Excact cource, set 2 more, and delete them again.
I have checked the time on my computer, and it match excactly with gametime.

kallemans
Post by iconPost by Hardtack | 2020-11-22 | 16:44:08
I entered two programmed commands (with no immediate commands pending) and deleted them again. This resulted in two Game_AddBoatActions, the first containing the two programmed commands, and the second containing one immediate command:

{"@class":".LogEventRequest",
"eventKey":"Game_AddBoatAction",
"race_id":440,
"leg_num":1,
"ts":1606062300000,
"actions": [{"values":[
{"ts":1606065900000,"heading":63,"autoTwa":false},{"ts":1606066500000,"heading":33,"autoTwa":false}],
"type":"prog"}],
"requestId":"637416590652980000_22"}

and after deleting them

{"@class":".LogEventRequest",
"eventKey":"Game_AddBoatAction",
"race_id":440,
"leg_num":1,
"ts":1606062360000,
"actions":[{"value":63,"autoTwa":false,"type":"heading"}],
"requestId":"637416591186130000_23"}

The Dashboard reflects this correctly in the Race Log and Race Status:


... but the second command is indeed a bit surprising. I think this can be considered a bug in the game UI.


Post by iconPost by kalle | 2020-11-22 | 17:41:30
@ Im happy im not craisy. We have a problem here i think
border
Topics list
Posts
border
23
border
border
10
border
border
5
border
border
16
border
border
5
border
border
3
border
border
1
border
border
Copyright 2009 by ZEZO.ORG. All Rights Reserved.