Silent debugging
Post by iconPost by Fly_Star_TVD | 2019-12-17 | 23:10:24

Any idea to hide the infobar with the new Chrome's version ?
I can't find the silent debugging.

Thanks

commenticon 13 Comments
Post by iconPost by toxcct | 2019-12-17 | 23:16:55
There is a reason why this banner is there.
It is to warn about something potentially harmful for your privacy.

Obviously, the VR Dashboard is safe, it won't steal your data. But Chrome knows nothing about it in particuliar, hence the warning.

If you want to avoid it, the open a dedicated chrome instance with the "flag" disabled.
(it has already been explained here, but I can't find back the discussion)
Post by iconPost by mak08 | 2019-12-18 | 09:41:41
This looks like a bug in Chrome.
There used to be a flag chrome://flags/#silent-debugger-extension-api
but it's gone in the latest Chrome version 79.0.3945.79.

If you start TWO debugging extensions and close one of them, the banner goes away, but the other extension remains attached and keeps running.

Post by iconPost by zezo | 2019-12-18 | 12:00:10
It might not be a bug but a feature. The dashboard may not be stealing your data, but another extension could be doing it, and the flag is (was) global. So they may have removed it on purpose, but I could not find anything about it.
Post by iconPost by GeGaX | 2019-12-20 | 18:42:37
I found the solution for Windows.

# If you have a Chrome shortcut on the Desktop:
=> Right click / Properties / Shortcut tab
In target, replace the line with this one:

"C:\Program Files\Google\Chrome\Application\chrome.exe" --silent-debugger-extension-api

then Apply.



# If you do not have the Chrome shortcut, you need to create it
=> On the Desktop, Right click / New / Shortcut and paste this path :

"C:\Program Files\Google\Chrome\Application\chrome.exe" --silent-debugger-extension-api

Give a name to the shortcut (ex: GChrome)


EDIT:
For macOS users, open the terminal and past this path :

/Applications/Google\ Chrome.app/Contents/MacOS/Google\ Chrome --silent-debugger-extension-api

then Enter


Explanation :
The Chrome flag #silent-debugger-extension-api has expiry milestone currently set to 77.
https://github.com/chromium/chromium/blob/master/chrome/browser/flag-metadata.json#L3282
Post by iconPost by zezo | 2019-12-20 | 19:20:38
Thanks. Works on linux too.

I run a separate instance from a command line anyway because of the crash (like google-chrome --user-data-dir=foo )

Adding --silent-debugger-extension-api to that removed the warning.

Post by iconPost by Fly_Star_TVD | 2019-12-22 | 17:21:06
Thanks a lot
Post by iconPost by Mcfly BSP | 2019-12-23 | 12:48:27
Thx Romain !
Post by iconPost by QuiVaSadoVaMaso2 | 2019-12-23 | 20:34:39
Thank's Romain.
All is ok for Mac & PC
Post by iconPost by DeskSailor | 2021-05-19 | 21:17:35
Has something changed that means even adding --silent-debugger-extension-api now won't work?

Tried Run, command line as administrator and the shortcut.

Chrome Version 90.0.4430.212 (Official Build) (64-bit). Win 10 all updated.

Post by iconPost by Hardtack | 2021-05-23 | 12:31:14
Nothing was changed in Dashboard.
The flag still works for me (Chromium/Linux 90.0.4430.93)

Post by iconPost by DeskSailor | 2021-05-25 | 10:10:53
Although mine is a slightly later version apparently I hadn't been exiting Google Chrome fully and it was still running in the background, even though I was exiting the same way I always have, clicking the X top right.

I should have been using Exit from the menu, I'm told by the Chromium dev lot.

Anyway, normal service resumed and I post this in case some other player gets the same experience.
Post by iconPost by DeskSailor | 2021-05-25 | 10:10:54
Duplicate post text deleted.
Post by iconPost by CRISTAU | 2021-05-28 | 11:06:15
Thanks, it works also with Edge where VR works better than in Chrome

border
Topics list
Posts
border
1
border
border
Copyright 2009 by ZEZO.ORG. All Rights Reserved.