Yet another Bug at VR
Post by iconPost by toxcct | 2018-06-29 | 09:55:17

I found this today...
How the hell can I know which heading I'm targetting then ?!



Well done guys. Looks like you unit tested your code perfectly once again ! (-_-)

commenticon 28 Comments
Post by iconPost by zezo | 2018-06-29 | 10:01:13
It would be interesting to see the actual server-side values. The interface does some heuristics to hide the fact that client and server wind direction don't match, so when at fixed TWA the headings do not match and vice versa.
Post by iconPost by zezo | 2018-06-29 | 12:50:26
Seems to be a feature of the new version ;-)

Got -301 too, at twa 115. Server says 58.7 so it's about right modulo 360.

There is new version in the store, indeed. Changelog says:

- Program of upcoming races
- Engine improvement (waypoints, grounding, trail, ...)

Post by iconPost by YourMomSA | 2018-06-29 | 13:00:37
On the plus side, it sounds like they believe they've made some improvements related to waypoints, groundings, and trails, which all needed work.
Post by iconPost by YourMomSA | 2018-06-29 | 14:43:37
The "trail" improvement seems like a strong improvement, at least for one's own trail. I've been messing around in Atlantic Record while collecting cards until the next good starting opportunity, and I'm suddenly seeing much better precision in my trail history than I saw yesterday. Hopefully that works for other people's trails too... so that in coastal races, people will stop thinking the winners sailed over land, etc.
Post by iconPost by Spion 007 | 2018-06-29 | 15:55:23
Looks like a general client problem, check the wind direction at the cursor in the picture above -184 degrees... Modulo 360 it is the correct value...

Post by iconPost by Spion 007 | 2018-06-29 | 16:05:38


Post by iconPost by Ursus Maritimus | 2018-06-29 | 17:31:50
-300 is like 60, that's all. in other words a 360 offset
Post by iconPost by toxcct | 2018-06-29 | 21:51:22
That's it, but it's plainly stupid, once again
Post by iconPost by Ursus Maritimus | 2018-06-29 | 22:06:53
indeed, that it is ;)

but, the webclient doesn't need to refresh every 5 seconds and doesn't seem to crash every couple of hours. curious to see if the steering and waypoints behavior improved as well. (sort of release notes with the android app:

- engine improvements (waypoints, grounding, trail, ...)
- bugfixes and performance improvements
Post by iconPost by Alex Wind | 2018-06-30 | 11:10:30
I ve got the same bug. It's not top for rig heading.
VR is not very serious, as usual..
Post by iconPost by toxcct | 2018-06-30 | 11:58:09
and the same appears in the wind info beside the mouse cursor...
When the wind comes from 0° to 10°, it even displays as : "0-5°".

Shitty !
Post by iconPost by MidnightFoiler | 2018-06-30 | 14:30:34
Am i right in thinking you now have to zoom out quite a lot from max zoom to see your predicted route... is this perhaps to prevent you trying to get too close to land? ... seems to be ok now, wasn't before the start..

Post by iconPost by toxcct | 2018-06-30 | 21:06:04
Ah ah, even better. Now, the compass says I'm heading -474° ! ROTFL
Post by iconPost by Caledonia | 2018-07-01 | 04:00:30
Yes -474 as my heading has got me scratching my head too? What is going on? I'm pretty decent with mathematics and general route finding but.... I thought if I added 360 to any of the minus figures VR had for my boat or the wind on screen then I got the correct numbers. But -474 still leaves me with -114 and so how does that relate to my current heading of about 245? I am thinking perhaps I need to add another 360.
It's a bit of a joke really?
I'm not one to criticize usually but it seems for every improvement VR makes there is something that deteriorates.
Post by iconPost by zezo | 2018-07-01 | 09:33:15
-114 is exactly 246. The minus sign means left rotation from the zero/North direction.

The normalization of headings/TWA is surprisingly tricky, but they'd been doing it right for more than 10 years. And it's written in a high level language so it should not be something like unsigned/signed integer overflow.

Edit: on a second thought, C# does have unsigned types.
Post by iconPost by MidnightFoiler | 2018-07-01 | 09:50:17
Anyone else getting ridiculous routing from the VR programmation in the round ireland race - like 18hrs to do 10nm at 80 TWA?

Would post an image but can 't work out how it's done..

Post by iconPost by zezo | 2018-07-01 | 09:59:58
Any chance you are using the wrong sail with no auto sails? The LG and HG have very low speed at 80.
Post by iconPost by MidnightFoiler | 2018-07-01 | 10:10:08
Yes, thanks! I literally just worked out that it's because I had turned off auto-sail while sailing close to the switch over point and wanted to make sure I didn't give myself another unnecessary sail change penalty having done that earlier!
Post by iconPost by MidnightFoiler | 2018-07-01 | 13:27:38
Sometimes, the bug is sitting in your seat... Just ran aground, was swearing thinking it had run aground on a waypoint I had carefully placed just off a point ... but thanks to the dashboard I worked out I'm an idiot since my waypoint was much further on so I hadn't check the line past that other point carefully enough... doh ... or it did appear to be ok when I checked but I'm not sure of that.

Good news is getting off was fairly painless (unlike I experienced on my first VR race). I was back going again and it was interesting looking at the dashboard...

22:44:06 going full speed.
alert sent to my phone, run to my pc, login to game..
22:46:00 Command @22:45:48 Actions: HDG=167
22:46:01 Vc = 0.03, Gybe + sail change confirmed
22:46:28 Vc = 1.95
22:47:00 Command @22:46:56 Actions: HDG=257
22:48:26 Vc = 3.42
22:48:39 Vc = 11.34
(times are UTC+10)

Boat track in client did a funny jump back to the north once it going again - bit like the drag back aground people have mentioned before but I didn't end up aground again - I think the client updated with more speed on gybe south from being aground than dashboard showed so it corrected for this.





Post by iconPost by theo | 2018-07-01 | 15:12:52
I only wish we had a clear solid game
I see it as well, does everybody see it?

Post by iconPost by toxcct | 2018-07-01 | 16:08:08
I think everybody sees it. And if you don't, just activate and deactivate the "lock TWA", and voilà...
Post by iconPost by zezo | 2018-07-03 | 15:17:49
I just noticed that you can unwind the compass. Make one turn clockwise to increase the number by 360 and get into the normal range.
Post by iconPost by Lazy_Hikers_Finland | 2018-07-03 | 21:52:21
Yes, just like in real sailing. Sail many 360s and suddenly you are headed to the right direction.

Thats what they promised us - real life sailing in real life conditions. (Oops, I did it again)
Post by iconPost by Inicio | 2018-07-03 | 22:08:23
Yes!
Thanks!

Post by iconPost by toxcct | 2018-07-03 | 22:19:06
You want a secret tip ?
make several turns around the compass, it should enable the Unity Debug Console ^^
Post by iconPost by pmangino | 2018-07-06 | 19:42:06
This is ridiculous..!!!
I'm feed up with this game...

Post by iconPost by turb | 2018-07-08 | 22:16:59
Almost 10 days and still not corrected...
VR crew should be in Bermuda for departure of Atlantic Anniversary and will extend their holiday with the cash collected during all this year...
Post by iconPost by Lasse | 2018-07-09 | 22:35:41
No more real money from my side to VR from now. I play for game money only.
border
Topics list
Posts
border
2
border
border
4
border
border
6
border
border
8
border
border
48
border
border
17
border
border
4
border
border
Copyright 2009 by ZEZO.ORG. All Rights Reserved.