Vendee Arctique
Post by iconPost by Luis75 | 2020-07-08 | 17:46:10

Hi all,
today I noticed on VR that buoy #3 has been moved towards east. Is it me or it really happened?

commenticon 46 Comments
Post by iconPost by Luis75 | 2020-07-08 | 17:47:20
I would say towards north-east and the new position is quite faraway from the old one
Post by iconPost by BooBill | 2020-07-08 | 18:47:29
Jacques Caraës, Race Director of the Vendée – Arctique – Les Sables d’Olonne:“By repositioning the Gallimard mark, Race Management and the weather cell are simply trying to refine the ETAs (estimated time of arrival). A high pressure system is settling in over the Azores, which the back runners might well have become ensnared in if the initial positioning had been retained. Positioning the mark at 46°20N – 015°W enables us to pretty much stick to the initial format of around 12 days. It is likely there will be a bunching up of the fleet with around thirty hours separating the first and last boats. The skippers in the Class IMOCA have really had their work cut out in the first part of the race. When you sail a course from north to south, you know that you’re going to pass through various weather systems rather than accompanying them: low pressure systems, ridges of high pressure, sustained or light winds, all of which enable you to play around with strategies and work on points of sail. This is evidenced by the fact that the IMOCAs with classic (straight) daggerboards are still in the match and it’s very difficult to predict who will make the podium!”
Post by iconPost by UUnet | 2020-07-08 | 20:10:20
Thx @BooBill
Post by iconPost by Dutch Dream 3 | 2020-07-14 | 15:28:52
How do I use zezo and VR dashboard
Post by iconPost by Luis75 | 2020-07-08 | 23:20:05
Thank you @BooBill
Post by iconPost by etrille17 | 2020-07-09 | 07:39:49
Merci pour les explications qui sont claires et nettes.
Post by iconPost by Luis75 | 2020-07-09 | 09:48:18
Re: passing buoy #3. Is it possible in your opinion to pass west of the buoy cross the line I see on the dashboard and come back?
Post by iconPost by Hardtack | 2020-07-09 | 10:52:49
No, I don't think so (assuming you mean the IOC UNESCO mark at 62°N 25°W). You have to go counterclockwise around it.
Post by iconPost by Luis75 | 2020-07-09 | 10:58:29
Yes I mean IOC Unesco mark. Well next time I use a guest account and I try it...
Post by iconPost by Luis75 | 2020-07-09 | 10:58:41
Post by iconPost by YourMomSA | 2020-07-09 | 20:14:44
Anybody know much about how VR processes waypoints relative to mark validations? For example, is there an oddity if you hit multiple course changes due to waypoints all within the same minute?

I had two waypoints at the turning mark. One just NE and one just NW, and then a third down S. But it failed to validate the mark. I've used similar techniques plenty of times before without problems. I'm not sure what happened. It looks like Titanic and Kallemans had similar issues. Presumably others too. Unfortunately, I was in a business meeting and didn't notice until 10 minutes later, and then I had to focus on work so I couldn't even hand-steer it properly. So I must have lost half an hour or more. Might get some of it back with fleet compression, but the race is shot.

it's ok... I can live with it. It happens to everyone occasionally, particularly if you try to push the limits on roundings. And I set those waypoints on my phone when I woke up around 6 AM, so maybe I simply got it wrong and failed to notice.

Looking at my track, it doesn't look like my boat ever turned West. It looks like it went to the NE waypoint and then turned South. So I've been wondering if maybe it processed both waypoints in the same minute and somehow got confused.

Either that, or maybe being so far North on the map confused it. Maybe when you're North of 60N, you need to sail more than 2 or 3 second of longitude to register the movement? Now that I think about it... I'm starting to think that's the most likely explanation... since it seems to have been an issue for more than just me.
Post by iconPost by SlyStarLeRetour | 2020-07-09 | 21:36:04
We experienced same issue with some of our team members; coordinates were similar but some passed and some did not. Strange.
Post by iconPost by smit | 2020-07-09 | 21:50:59
I was 30-40 minutes behind you and noticed your routing change to make the mark. I looked at mine - similar three waypoints (but I haven't gotten as fine tuned as you and the other leaders). The buoy had not turned green and the rotating arrows still indicated I needed to round the mark but I was SW of the mark already. I hesitated for a few minutes and when I went back it had changed to green. My routing at that time showed the horizontal offset typical when changing course and VRs dead reckoning issue. My track shows the turn south (at waypoint 2) much further west than I had set it.
Post by iconPost by Hardtack | 2020-07-09 | 21:42:09

There is one thing I noticed today when fine-tuning my waypoints. I first had two waypoints at the same latitude 62°00'01", but they weren't aligned on the Dashboard map as I expected. I thought that waypoints are placed at integer second coordinates, because that's what the VR interface suggests. Alas, as with heading/TWA, this turns out to be wrong.

This is what I got when I just set a waypoint at 40°00'01"N 70°00'01"W in the Atlantic Record with a guest boat:


So the longitude value actually is 70°00'01.9" !

I didn't do the math, but obviously when trying to round the mark with a 1" margin
on the VR display, things can easily go wrong. It seems that I was lucky this time.
Post by iconPost by YourMomSA | 2020-07-09 | 22:00:04
Very interesting, thanks. My waypoints were set on my phone, so no dashboard. I set them at

62 00 01, 24 59 59
62 00 01, 25 00 01
61 58 00, 25 00 00

If I had been on my computer and looked at the dashboard, would the dashboard have shown the true locations?

Stil uncertain though how that arrangement could have missed the buoy validation, even if they were off by half a second. Unless the discrepancies can be off by more than that. I guess I need to give it a bit more margin in the future. Particularly in extreme latitudes, where coordinates can get a little squiffy.
Post by iconPost by Hardtack | 2020-07-09 | 22:28:16
The dashboard shows the true locations on the map, but it does not display the numeric lat/lng values. Actually it only shows line segments between the waypoint, something that could be improved.

If your bearing to the first waypoint was 8° or 10° and the actual latitude was, say, 24°59'59.95" then you may have missed the mark (I think, haven't done the math).

But if you say your boat never turned west I don't understand how this could happen. It should have sailed at least 1" between the NE and NW waypoints.

Note that VR are truncating the centiseconds. The positions can be off by a whole second away from the equator / Greenwich.

Post by iconPost by YC6211 | 2020-07-10 | 00:34:37
I had the same waypoints set initially, but after playing around with a great circle path tool I noticed that the bearing from 62 00 01, 24 59 59 (WP1) to 62 00 01, 25 00 01 (WP2) was the same as from WP1 to the mark. It didn;t have the resolution confirm whether it passed north of the mark or not, but it was withing a few meters either side. It's possible that this route didn't actually pass to the north of the mark. I set my WP to 62 00 01, 24 59 59 and had no issues.
Post by iconPost by Luis75 | 2020-07-09 | 22:38:48
One more thing: I noticed that the mark on vr was not exactly positioned at 62N25W.
Fine tuning the wp, I noticed that setting the wp west of the mark at 62N 25°00'01' (01' should be around 30 meters) the wp was east of the mark. I don't know if this is a graphical problem of the VR interface or if it has something to do with the discrepancy you mentioned. As I said that difference of 0.9'' should be around 30 meters (27 exactly) which is quite a lot when you push the passage. Then I moved the third wp at a safe distance, but in this way I lost something like 40 positions.
Post by iconPost by Hardtack | 2020-07-09 | 23:00:39
No, according to the Game_GetBoatState message the mark is at 62N 25W exactly. The VR interface is too inaccurate, you won't be able to see it there, even if you use a waypoint to check the position, because VR are truncating the centiseconds. See above.
Post by iconPost by YourMomSA | 2020-07-10 | 00:05:47
Thanks, guys. I think this explains it. I've done hundreds of races, and when you push the limits, you'll occasionally miss a mark or run aground. It's impossible to know if my boat actually turned West or not (Waypoint 2 said it should have sailed 253 for a seconds of longitude), but even if it did, it sounds like the rounding of centiseconds, plus my boat coming in at 008, must have tripped it up. Either that, or due to the northern latitude, my Westerly leg was so short that it somehow confused the buoy confirmation logic. I think the northern latitude must be part of it, simply because the problem happened with more racers than usual.
Post by iconPost by BooBill | 2020-07-10 | 00:59:37
Follow up question. Since waypoints can only be set using the graphic interface (please tell me if there is another way), the finest you can get it is 1 pixel, right? If you set your waypoints using a higher resolution screen, can you get greater accuracy?

After grounding countless times I now try to set waypoints in fullscreen mode on my 27" iMac. Visually you can see a lot more, but is that actually giving you greater fine control than say using a phone screen?
Post by iconPost by Hardtack | 2020-07-10 | 09:19:08
If you spin the helm control counterclockwise several times, the unity player shows some setup and debugging info, including the screen resolution. Mine says 1080x574. Be careful, the info is overlaying the game interface, but the game interface still works.
I was just reminded of this when I turned my boat around 180°...

Post by iconPost by BooBill | 2020-07-10 | 12:21:06
Remind me to try that AGAIN when I don't have program points set. You warned me.
Post by iconPost by Hardtack | 2020-07-10 | 12:46:31
Lol. I kept further west than most of the fleet after the UNESCO mark and I think this gained me a few places. Not sure why I tried to ruin my race. I usually use a guest boat for experiments.
Post by iconPost by YourMomSA | 2020-07-10 | 13:52:14
I hope your decision to stay a little West pays off... I stayed... a little more West. (25W had the max breeze for a few hours, so I sailed straight down it, with an attitude of "I shanked this race, so I'll do this now and figure the rest out tomorrow". It was that or Raketa's move East. I liked that move, but wasn't quite far enough back to take that big a risk. I think he's going to be looking pretty good in 12 hours or so... and then will drop back when he has to deal with headwinds... unless the forecast changes.

Oh, and... I like your team.
Post by iconPost by Hardtack | 2020-07-10 | 23:01:02
Thanks :-)
Post by iconPost by MidnightFoiler | 2020-07-11 | 04:21:04
Interesting YM, I'm not sailing with full options this race but just to gain some VSR points and so decided to push that one to the limit as an experiment and passed ok.

My coords checked in dashboard raw log were
62.00018 -24.99986 - only 21m NE of mark
62.00001 -25.00008 - only 4.5m W of mark
and then south at heading 182 to a wpt much further out that I went back in and deleted.

I wonder if I got lucky and my 2 wpts happened to not be in the same minute on the server? 25m would have only taken about 4 secs so that's a 1 in 15 chance.

There was me thinking I have finally found one aspect of the game that was accurate a reliable!

Might finish my Atlantic card collection run with a series of wpts 20 secs apart and see if any appear to be ignored...

Post by iconPost by MidnightFoiler | 2020-07-11 | 09:33:27
Did my experiment. I put in 6 waypoints about 20 secs apart and it followed them all according to dashboard track. If it combines within 1 minute then it should have skipped 2 or 3 of them...
Post by iconPost by YourMomSA | 2020-07-11 | 12:36:55
Maybe I just botched it on my phone right after waking up. I'd say that's likely if not for the observation that a bunch of other people similarly missed the mark. Weird.
Post by iconPost by BGSteMarine | 2020-07-11 | 13:34:27
Hi YMSA. You have probably encountered the same problem as some players from my team, and passed left of the buoy with your 1st Way Point.
The truncation of the subsecond decimals on VR User Interface has been fatal !
A little schema for explanation :

Post by iconPost by BGSteMarine | 2020-07-11 | 13:35:27
Ooops !! Image too large ! sorry about that. I have had to try a couple of times ;-)

Post by iconPost by YourMomSA | 2020-07-11 | 15:39:03
Great analysis! An additional thought on this point... Your diagram uses squares, but at such a northern latitude, it would be more like narrow rectangles... which would probably exaggerate the implications. It simply never occurred to me that an angle of roughly 8 degrees could possibly be enough to miss to that side.
Post by iconPost by BGSteMarine | 2020-07-11 | 22:50:27
You are 100% right! I made a projection on a square diagram, but with spherical math calculations. This is why the apparent angle on the diagram is greater than 8 degrees.
My first calculation tool was based on plane geometry and I missed one buoy with that ! I'm now using spherical formulas in my excel tool.
Sample for your case if your way point where at 62�00'01.7" and 24�59'59.7" (sorry, it's in french, but the visual is quite clear) :

Post by iconPost by MidnightFoiler | 2020-07-12 | 12:06:09
I assumed it rounded up/down the seconds but sounds like you are saying it truncates down always Benoit?

I just brought up YM's track in dashboard without all the others in dashboard and it does indeed show the arrival from west of the bouy. Oddly the exit is the east of the bouy until you turn around to come back. So it would still seem there was something wrong with the 2nd waypoint (or the track is incorrect) .... and if it was a real race you would need to go back and re-round as all you did was unwind your rounding the wrong way :-P
Post by iconPost by BGSteMarine | 2020-07-12 | 17:27:27
Yes. It's not a rounding but a pure truncation! So the uncertainty is of 1 second and not 0.5 :-/ We need to be careful, or to look at the sub-second decimals for the buoy and the WP positioning.

For YMSA trace, not sure, but I have noticed that for my team members who have had a very aggressive turn with 2 way points within the same minute, the trace seems to only show the second WP, and erase the 1st one ...
Post by iconPost by PML | 2020-07-12 | 23:13:22
Do we also have to worry about the heading displayed in the Waypoints window (which is always an integer) to be either truncated or rounded up ?
Post by iconPost by MidnightFoiler | 2020-07-13 | 01:18:53
Note the next waypoint is shown in the dashboard as 46 20 00N 15 00 07W is dashboard but this is also truncated from 46.333604812622, -15.002098083496 = 46º20'0.977"N 15º0'7.553"W

@PML It must be rounded or truncated. Hard to say which. Possibly rounded since boat heading or twa appears to be rounded. This tends not to be so critical but I would always try to have a degree margin on twa if trying to avoid an auto sail change and a few degrees while on waypoints or heading.

@BGSteMarine I tried to reproduce the ignoring of waypoints with a series of 6 wpts 20s apart but it showed them all in the track. Maybe they need to be closer and/or a more radical change of direction than I tried. I have not seen this problem myself and have done similar things quite often. YMSA's track seems to have the 2nd waypoint ignored not the 1st.

Post by iconPost by YourMomSA | 2020-07-13 | 04:07:05
It's seriously possible that I simply made a stupid mistake on my phone at 6 AM and placed the second waypoint on top of the first. I thought I did it properly, but who knows. It's hard to even get my eyes to focus well enough to read the numbers in that situation. :-)
Post by iconPost by Hardtack | 2020-07-13 | 09:39:09
It's just one hour before the first (virtual) boat are going to round the Gallimard waypoint, but I just now noticed that the dashboard displays a lot of tracks that seemingly did not clear the UNESCO waypoint correctly (but were "validated" by VR).

I don't know what to make of it. If an incorrect looking track was actually ok, maybe things can go the opposite way as well.

I'm still assuming that the dashboard shows the location of waypoints correctly w.r.t the location of the marks and I've set my waypoint as close as I could.
Just don't shoot me (or Xeelee, wherever he may be :-)) if it goes wrong.

Post by iconPost by BooBill | 2020-07-13 | 11:02:22
Well, I missed it, then I didn't.

Set Actions: WP: 46°19'58"N 15°00'08"W; WP: 46°21'21"N 14°58'26"W;

I sailed for 2 movements of the boat past the mark, still hasn't validated, my turning point in the track shifted NW after the fact. Fuck, how could those waypoints miss it?

Turn back and before I get back to the mark, it validates.

BGSteMarine, is that model you posted above available? My fear was that even though my turn point was below the mark, if I turned too tight I'd pass back north of the mark. Did that happen, or is VR just messed up? Or, I didn't wait long enough for the validation and they just shifted by turning point visually to mess with me?
Post by iconPost by YC6211 | 2020-07-13 | 12:07:59
I set my waypoint at 46°20'00"N 15°00'08"W but used the raw log to get a decimal coordinate of 46.33354 -15.00216 and a second waypoint to have an exit heading of 39°. That was the closest I could get it to the mark and it validated within 60 seconds of rounding.
Post by iconPost by BooBill | 2020-07-13 | 13:59:39
To make it worse. Looking at my track in the VR client, it shows I went about half a mile past the mark, then turned north west initially. It's indicating I sailed well past the mark and turned back before reaching the waypoint where it should have turned to 40 degrees. Yet clearly you can see from the waypoints I cut and pasted directly from the dashboard I was programmed to turn just 65m past the mark.

I didn't bitch about the northern mark since my problem there was less than some others, but in that case, as well it showed me sailing west for half a mile, even though my two waypoints were 02" apart.

Looking at Buddha's track (cause it nicely contrasts in pink) and it is possible to make a perfect turn exactly on the mark. I'm just at a loss as to how.
Post by iconPost by YourMomSA | 2020-07-13 | 15:45:24
Historically, a couple well-placed waypoints have achieved it reliably, and I'm sure that's what Buddha did. It seems there are simply some circumstances that can cause a "miss" if you push it that close, as happened to me and others at the north mark.

Your situation at the south mark is a different bug, which I have experienced but don't fully understand either so I can't explain it exactly. If you're watching your boat go around waypoints, and you delete all of your remaining waypoints, sometimes it'll back up and have your boat follow a path beyond a prior waypoint. I had a race a year or so ago where I did that when rounding a headland... when it came time to switch from waypoints to VMG sailing... I was running in the top 5... And then suddenly my boat went off beyond the headland before turning up, having lost some critical upwind distance. I dropped to something like 25th. Decent finish, but a real bummer when you're in the endgame for a potential win.

I remember someone subsequently saying something about exiting the UI and re-entering when killing waypoints in situations like that. I'm not sure what it does or why to do it, but I've been doing it since and the problem hasn't recurred. I'll usually wait until I'm around the last waypoint that I actually wanted to retain... then exit the game... then go back in at least a minute later, and delete the next waypoint... then exit the game... then come back in at least a minute later and set my new course. PITA, but seems to avoid the issue.
Post by iconPost by BooBill | 2020-07-13 | 15:54:06
That's very helpful YMSA. In both cases, I deleted my waypoints as soon as I had rounded the mark. Once to go back, once to switch to TWA. It does appear that it then acts as if the waypoint was never there.

I have to develop a bit of patience I think.
Post by iconPost by BGSteMarine | 2020-07-13 | 21:30:42
Yes. always the same trap! Need to wait for the end of the next 5' server cycle before removing the last Way point!!
And if something strange in your trace, just get out of the race and come back before taking any decision!!

Post by iconPost by MidnightFoiler | 2020-07-14 | 15:00:42
I don't know if it still happens but there was often a bug where you would pass a waypoint and then turn around and point back at it if you watched the boat go through waypoints. While it sounds like it should just be a UI issue it even used to result in the same on the server. Therefore I never watch my boat pass through waypoints and re-enter once I see the new heading in dashboard (or know from expected timing that if I re-enter it will do an extra server update and will be past the waypoint).

You can still watch your boat in dashboard and even update other boats by clicking them in the rankings without entering the race - click your "rank" to bring it up. Bit tedious these days though with dashboard zooming back out each update.
Topics list
Copyright 2009 by ZEZO.ORG. All Rights Reserved.